Autore: Andrea Pacchiarotti

Stampa unione per personalizzare le etichette o le buste da inviare in modo massivo

Etichette: questa procedura è utile per creare un foglio di etichette (detto Documento principale) con gli indirizzi dei destinatari contenuti in un’origine dati (detta Lista di distribuzione) da apporre sulle buste da inviare ai destinatari nell'elenco indirizzi. Combinando questi due documenti attraverso la stampa unione si ottengono le etichette di indirizzi.

Buste: questa procedura è utile per creare un insieme di buste (detto Documento principale) con gli indirizzi dei destinatari contenuti in un’origine dati (detta Lista di distribuzione). Ogni busta conterrà un indirizzo della lista di distribuzione.

Preparare il documento principale per le etichette o le buste

In entrambi i casi si inizia da Scheda Lettere / Inizia stampa unione / Creazione guidata stampa unione…
A destra si apre il riquadro della Stampa unione nel quale si sceglie l’opzione Etichette (oppure Buste) e si clicca in basso Successivo: Documento di partenza per scegliere il file di partenza; dato che si è già aperto un documento è possibile optare per Cambia il layout del documento e cliccare in basso Opzioni etichette… per scegliere il fornitore di etichette e successivamente il tipo (nel caso delle buste scegliere Opzioni busta… per scegliere il formato della busta).
Stampa unione per le etichette di Andrea Pacchiarotti Stampa unione per le etichette di Andrea Pacchiarotti

Stampa unione per le etichette di Andrea Pacchiarotti

Se il proprio fornitore o il tipo non è presente in lista, è possibile cliccare il pulsante Nuova etichetta… per crearne una personalizzata dalla finestra che si apre.
Stampa unione per le etichette di Andrea Pacchiarotti

Al termine dell’impostazione del tipo di etichetta scegliere in basso Successivo: Selezione destinatari.

Invece nel caso delle buste comparirà la seguente finestra che dal pulsante Carattere… permette di modificare la formattazione dei campi relativi al destinatario
Stampa unione per le buste di Andrea Pacchiarotti

Configurare la lista di distribuzione e collegarla al documento principale, il foglio delle etichette o le buste

L’origine dati, che può essere un foglio Excel (se si hanno C.A.P. formattarli come testo per evitare di omettere gli zeri), una directory di contatti Outlook (assicurarsi che sia il programma di posta elettronica predefinito), un database Access, contiene i record usati da Word per implementare le informazioni per creare le etichette o le buste.
Se manca la lista di distribuzione è possibile crearla durante la stampa unione scegliendo l’opzione Crea un nuovo elenco e poi Crea… (in tal caso Word creerà un file Access), oppure si può usare l’opzione Seleziona dai contatti di Outlook o infine l’opzione Usa elenco esistente e cliccare Sfoglia… per recuperare il file Excel o Access.
Stampa unione per le etichette di Andrea Pacchiarotti Stampa unione per le etichette di Andrea Pacchiarotti

È possibile modificare l’elenco destinatari cliccando Modifica elenco destinatari…, si aprirà la finestra Destinatari stampa unione che, dopo aver selezionato in basso a sinistra il file dell’origine dati, consente di perfezionare l'elenco aggiungendo, modificando, eliminando, filtrando od ordinando record, permette inoltre di trovare duplicati, destinatari e convalidare indirizzi.

Aggiungere gli indirizzi alle etichette o alle buste

In questo passaggio, a cui si è arrivati cliccando in fondo al riquadro stampa unione il link Successivo: Disponi etichette (o Disponi busta),  è possibile inserire campi unione nel documento principale per variare i contenuti a seconda della persona che riceve la lettera, ad esempio si possono aggiungere i campi nome, cognome, stipendio, ecc.
Stampa unione per le etichette di Andrea Pacchiarotti

Da Blocco di indirizzi… è possibile aggiungere in un blocco unico e indivisibile tutti i campi offerti di default da Word. 
Apparirà prima una finestra dov’è consentito scegliere un formato per la visualizzazione del nome del destinatario nella lettera.
Stampa unione per le etichette di Andrea Pacchiarotti

Da qui sarà possibile cliccare Corrispondenza campi… appariranno due colonne: a sinistra un elenco di nomi, a destra il nome campo per il nome comune, mappato a un'intestazione di colonna nel file dell'origine dati.
Se i nomi campo corrispondono alle intestazioni di colonna usate per i record nell'origine dati della lista di distribuzione, non fare nulla; se in un nome campo che dovrebbe corrispondere un'intestazione di colonna nell'origine dati compare (nessuna corrispondenza), fare clic sulla freccia del menù a discesa e scegliere il nome campo nell'origine dati della lista di distribuzione. Ripetere tutte le volte necessarie.
Stampa unione per le etichette di Andrea Pacchiarotti

Fatte queste operazioni comparirà sull'etichetta (o sulla busta) «BloccoIndirizzo» che conterrà tutti i campi di default di Word valorizzati con i propri record (i record reali si vedranno nel passaggio successivo).
Ma se nella creazione dell’elenco si sono inseriti campi non previsti da Word si dovrà cliccare Altro… che, oltre ad inserire i campi  non contemplati dall’applicativo, dà la possibilità di posizionarli separatamente.
Stampa unione per le etichette di Andrea Pacchiarotti

Una volta inseriti i campi si possono formattare a piacimento; prima di andare al passaggio successivo nel caso delle etichette è necessario cliccare il pulsante Aggiorna tutte le etichette per copiare il layout della prima etichetta sulle successive ed infine cliccando in basso dal riquadro stampa unione il link Successivo: Visualizzazione in anteprima delle etichette si possono scorrere, da Anteprima lettere, le lettere unite.
Stampa unione per le etichette di Andrea Pacchiarotti

Salvare il documento di etichette o di buste

Cliccando in basso il link Successivo: completamento unione e scegliendo Stampa… si manda direttamente alla stampante il risultato finale, mentre utilizzando Modifica singole etichette… (o Modifica singole buste) si può optare per il salvataggio delle etichette (o delle buste), la loro modifica e stampa successiva.
Stampa unione per le etichette di Andrea Pacchiarotti

Segui ML Training sui Social:
Facebook - LinkedIn - Twitter - Google+

Posted: 30 Ott 16 By: Category: Blog Read 1094 times

Autore: Andrea Pacchiarotti

Stampa unione per personalizzare le lettere da inviare in modo massivo

Utile per inviare messaggi di posta in modo massivo a destinatari presenti in una lista. Ogni lettera (detto Documento principale) è perfettamente identica all'altra, ma alcune parti potranno essere personalizzate con determinati campi contenuti in un’origine dati (detta Lista di distribuzione), come ad esempio Nome, Cognome, Stipendio, ecc.

La stampa unione recupera le informazioni dalla lista di distribuzione e le inserisce nel documento principale, creando una lettera personalizzata per ogni persona (detta Documento unito).

 

Preparare il documento principale

Per prima cosa si prepara la lettera ovvero il documento principale.

Poi si va su: Scheda Lettere / Inizia stampa unione / Creazione guidata stampa unione…

A destra si apre il riquadro della Stampa unione nel quale si sceglie l’opzione Lettere e si clicca in basso Successivo: Documento di partenza per scegliere il documento di partenza; dato che si è già preparata la lettera è possibile optare per Usa il documento corrente e cliccare in basso Successivo: Selezione destinatari

Stampa unione per le lettere di Andrea Pacchiarotti Stampa unione per le lettere di Andrea Pacchiarotti

Configurare la lista di distribuzione e collegarla al documento principale
Stampa unione per le lettere di Andrea Pacchiarotti
 Stampa unione per le lettere di Andrea Pacchiarotti
L’origine dati, che può essere un foglio Excel (se si hanno C.A.P. formattarli come testo per evitare di omettere gli zeri), una directory di contatti Outlook (assicurarsi che sia il programma di posta elettronica predefinito), un database Access, contiene i record usati da Word per implementare le informazioni per creare la lettera.

Se manca la lista di distribuzione è possibile crearla durante la stampa unione scegliendo l’opzione Crea un nuovo elenco e poi Crea… (in tal caso Word creerà un file Access), oppure si può usare l’opzione Seleziona dai contatti di Outlook o infine l’opzione Usa elenco esistente e cliccare Sfoglia… per recuperare il file Excel o Access.

È possibile modificare l’elenco destinatari cliccando Modifica elenco destinatari…, si aprirà la finestra Destinatari stampa unione che, dopo aver selezionato in basso a sinistra il file dell’origine dati, consente di perfezionare l'elenco aggiungendo, modificando, eliminando, filtrando od ordinando record, permette inoltre di trovare duplicati, destinatari e convalidare indirizzi.

Aggiungere contenuto personalizzato alla lettera

In questo passaggio, a cui si è arrivati cliccando in fondo al riquadro stampa unione il link Successivo: composizione lettera,  è possibile inserire campi unione nel documento principale per variare i contenuti a seconda della persona che riceve la lettera, ad esempio si possono aggiungere i campi nome, cognome, stipendio, ecc.
Stampa unione per le lettere di Andrea Pacchiarotti
Da Blocco di indirizzi… è possibile aggiungere in un blocco unico e indivisibile tutti i campi offerti di default da Word. 
Apparirà prima una finestra dov’è consentito scegliere un formato per la visualizzazione del nome del destinatario nella lettera.
Stampa unione per le lettere di Andrea Pacchiarotti
Da qui sarà possibile cliccare Corrispondenza campi…,  appariranno due colonne: a sinistra un elenco di nomi, a destra il nome campo per il nome comune, mappato a un'intestazione di colonna nel file dell'origine dati.
Se i nomi campo corrispondono alle intestazioni di colonna usate per i record nell'origine dati della lista di distribuzione, non fare nulla; se in un nome campo che dovrebbe corrispondere un'intestazione di colonna nell'origine dati compare (nessuna corrispondenza), fare clic sulla freccia del menù a discesa e scegliere il nome campo nell'origine dati della lista di distribuzione. Ripetere tutte le volte necessarie.
Stampa unione per le lettere di Andrea Pacchiarotti
Fatte queste operazioni comparirà sul foglio «BloccoIndirizzo» che conterrà tutti i campi di default di Word valorizzati con i propri record (i record reali si vedranno nel passaggio successivo).

Ma se nella creazione dell’elenco si sono inseriti campi non previsti da Word, come ad esempio Stipendio, si dovrà cliccare Altro… che, oltre ad inserire i campi  non contemplati dall’applicativo, dà la possibilità di posizionarli separatamente.
Stampa unione per le lettere di Andrea Pacchiarotti
Una volta inseriti i campi si possono formattare a piacimento; successivamente cliccando in basso dal riquadro stampa unione il link Successivo: Anteprima lettere si possono scorrere, da Anteprima lettere, le lettere unite.
Stampa unione per le lettere di Andrea Pacchiarotti

Salvare la lettera personalizzata

Cliccando in basso il link Successivo: completamento unione e scegliendo Stampa… si manda direttamente alla stampante il risultato finale, mentre utilizzando Modifica singole lettere… si può optare per il salvataggio delle lettere, la loro modifica e stampa successiva.
Stampa unione per le lettere di Andrea Pacchiarotti

Segui ML Training sui Social:
Facebook - LinkedIn - Twitter - Google+

Posted: 23 Ott 16 By: Category: Blog Read 1018 times

Autore: Andrea Pacchiarotti

Le funzioni di database eseguono un filtro invisibile in base ai criteri specificati e sui dati filtrati restituiscono il risultato di una delle funzioni sottostanti. 

Sintassi

DB.NOMEFUNZIONE(Database;Campo;Criteri)

Le funzioni di database prevedono i seguenti argomenti tutti obbligatori (argomento: Valore che fornisce informazioni per un'azione, un evento, un metodo, una proprietà, una funzione o una routine.):

Database   Intervallo su cui operare e che in prima riga presenta le intestazioni di colonna.

Campo   Numero di colonna (es. 6) o etichetta di colonna tra virgolette doppie  (es. "Stipendio") usata per il calcolo.

Criteri   Intervallo che contiene le condizioni da soddisfare nella seguente forma: almeno un'intestazione e subito sotto una cella con la condizione da soddisfare. Fare attenzione al fatto che l’intestazione sia perfettamente uguale a quella del database, ad esempio se una contiene uno spazio finale e l’altra no, non sono uguali. Ovviamente i criteri vanno decisi al momento e scritti in celle vuote, ad esempio sotto i dati.

DB.NOMEFUNZIONE sarà sostituita a seconda delle necessità dalle funzioni seguenti:
DB.CONTA.NUMERI, DB.CONTA.VALORI, DB.MEDIA, DB.MAX, DB.MIN, DB.PRODOTTO, DB.SOMMA, DB.VALORI, DB.VAR, DB.VAR.POP, DB.DEV.ST, DB.DEV.ST.POP

Di seguito il database di partenza

 

Questi invece sono i criteri

 

E queste le domande con le soluzioni, supponendo che TDB sia il nome dell'intervallo A1:H16

Segui ML Training sui Social:
Facebook - LinkedIn - Twitter - Google+

Posted: 18 Ott 16 By: Category: Blog Read 945 times

Autore: Andrea Pacchiarotti

Nel caso si utilizzino le funzioni di Excel nella programmazione VBA o si abbia l’applicativo in lingua inglese è utile conoscere la loro traduzione. 

Di seguito vengono elencate in ordine alfabetico le varie funzioni in italiano e in inglese fino alla versione 2016.

ITALIANO

INGLESE

A

 

ADESSO

NOW

AGGREGA

AGGREGATE

AMBIENTE.INFO

INFO

AMMORT

DDB

AMMORT.ANNUO

SYD

AMMORT.COST

SLN

AMMORT.DEGR

AMORDEGRC

AMMORT.FISSO

DB

AMMORT.PER

AMORLINC

AMMORT.VAR

VDB

ANNO

YEAR

ANNULLA.SPAZI

TRIM

ARABO

ARABIC

ARCCOS

ACOS

ARCCOSH

ACOSH

ARCCOT

ACOT

ARCCOTH

ACOTH

ARCSEN

ASIN

ARCSENH

ASINH

ARCTAN

ATAN

ARCTAN.2

ATAN2

ARCTANH

ATANH

AREE

AREAS

ARROTONDA

ROUND

ARROTONDA.DIFETTO

FLOOR

ARROTONDA.DIFETTO.MAT

FLOOR.MATH

ARROTONDA.DIFETTO.PRECISA

FLOOR.PRECISE

ARROTONDA.ECCESSO

CEILING

ARROTONDA.ECCESSO.MAT

CEILING.MATH

ARROTONDA.ECCESSO.PRECISA

CEILING.PRECISE

ARROTONDA.MULTIPLO

MROUND

ARROTONDA.PER.DIF

ROUNDDOWN

ARROTONDA.PER.ECC

ROUNDUP

ASC

ASC

ASIMMETRIA

SKEW

ASIMMETRIA.P

SKEW.P

ASS

ABS

 

B

 

BAHTTESTO

BAHTTEXT

BASE

BASE

BESSEL.I

BESSELI

BESSEL.J

BESSELJ

BESSEL.K

BESSELK

BESSEL.Y

BESSELY

BINARIO.DECIMALE

BIN2DEC

BINARIO.HEX

BIN2HEX

BINARIO.OCT

BIN2OCT

BIT.SPOSTA.DX

BITRSHIFT

BIT.SPOSTA.SX

BITLSHIFT

BITAND

BITAND

BITOR

BITOR

BITXOR

BITXOR

BOT.EQUIV

TBILLEQ

BOT.PREZZO

TBILLPRICE

BOT.REND

TBILLYIELD

 

C

 

CAP.CUM

CUMPRINC

CARATT.UNI

UNICHAR

CASUALE

RAND

CASUALE.TRA

RANDBETWEEN

CELLA

CELL

CERCA

LOOKUP

CERCA.B

SEARCHB

CERCA.ORIZZ

HLOOKUP

CERCA.VERT

VLOOKUP

CODICE

CODE

CODICE.CARATT

CHAR

CODIFICA.URL

ENCODEURL

COLLEG.IPERTESTUALE

HYPERLINK

COLONNE

COLUMNS

COMBINAZIONE

COMBIN

COMBINAZIONE.VALORI

COMBINA

COMP.ARGOMENTO

IMARGUMENT

COMP.CONIUGATO

IMCONJUGATE

COMP.COS

IMCOS

COMP.COSH

IMCOSH

COMP.COT

IMCOT

COMP.CSC

IMCSC

COMP.CSCH

IMCSCH

COMP.DIFF

IMSUB

COMP.DIV

IMDIV

COMP.EXP

IMEXP

COMP.IMMAGINARIO

IMAGINARY

COMP.LN

IMLN

COMP.LOG10

IMLOG10

COMP.LOG2

IMLOG2

COMP.MODULO

IMABS

COMP.PARTE.REALE

IMREAL

COMP.POTENZA

IMPOWER

COMP.PRODOTTO

IMPRODUCT

COMP.RADQ

IMSQRT

COMP.SEC

IMSEC

COMP.SECH

IMSECH

COMP.SEN

IMSIN

COMP.SENH

IMSINH

COMP.SOMMA

IMSUM

COMP.TAN

IMTAN

COMPLESSO

COMPLEX

CONCATENA

CONCATENATE

CONFIDENZA

CONFIDENCE

CONFIDENZA.NORM

CONFIDENCE.NORM

CONFIDENZA.T

CONFIDENCE.T

CONFRONTA

MATCH

CONTA.NUMERI

COUNT

CONTA.PIÙ.SE

COUNTIFS

CONTA.SE

COUNTIF

CONTA.SET.CUBO

CUBESETCOUNT

CONTA.VALORI

COUNTA

CONTA.VUOTE

COUNTBLANK

CONVERTI

CONVERT

CORRELAZIONE

CORREL

COS

COS

COSH

COSH

COT

COT

COTH

COTH

COVARIANZA

COVAR

COVARIANZA.C

COVARIANCE.S

COVARIANZA.P

COVARIANCE.P

CRESCITA

GROWTH

CRIT.BINOM

CRITBINOM

CSC

CSC

CSCH

CSCH

CURTOSI

KURT

 

D

 

DATA

DATE

DATA.CED.PREC

COUPPCD

DATA.CED.SUCC

COUPNCD

DATA.DIFF

DATEDIF

DATA.MESE

EDATE

DATA.VALORE

DATEVALUE

DATITEMPOREALE

RTD

DB.CONTA.NUMERI

DCOUNT

DB.CONTA.VALORI

DCOUNTA

DB.DEV.ST

DSTDEV

DB.DEV.ST.POP

DSTDEVP

DB.MAX

DMAX

DB.MEDIA

DAVERAGE

DB.MIN

DMIN

DB.PRODOTTO

DPRODUCT

DB.SOMMA

DSUM

DB.VALORI

DGET

DB.VAR

DVAR

DB.VAR.POP

DVARP

DECIMALE

DECIMAL

DECIMALE.BINARIO

DEC2BIN

DECIMALE.HEX

DEC2HEX

DECIMALE.OCT

DEC2OCT

DELTA

DELTA

DESTRA

RIGHT

DESTRA.B

RIGHTB

DEV.Q

DEVSQ

DEV.ST

STDEV

DEV.ST.C

STDEV.S

DEV.ST.P

STDEV.P

DEV.ST.POP

STDEVP

DEV.ST.POP.VALORI

STDEVPA

DEV.ST.VALORI

STDEVA

DISPARI

ODD

DISTRIB.BETA

BETADIST

DISTRIB.BETA.N

BETA.DIST

DISTRIB.BINOM

BINOMDIST

DISTRIB.BINOM.N

BINOM.DIST

DISTRIB.BINOM.NEG

NEGBINOMDIST

DISTRIB.BINOM.NEG.N

NEGBINOM.DIST

DISTRIB.CHI

CHIDIST

DISTRIB.CHI.QUAD

CHISQ.DIST

DISTRIB.CHI.QUAD.DS

CHISQ.DIST.RT

DISTRIB.EXP

EXPONDIST

DISTRIB.EXP.N

EXPON.DIST

DISTRIB.F

FDIST

DISTRIB.F.DS

F.DIST.RT

DISTRIB.GAMMA

GAMMADIST

DISTRIB.GAMMA.N

GAMMA.DIST

DISTRIB.IPERGEOM

HYPGEOMDIST

DISTRIB.IPERGEOM.N

HYPGEOM.DIST

DISTRIB.LOGNORM

LOGNORMDIST

DISTRIB.LOGNORM.N

LOGNORM.DIST

DISTRIB.NORM

NORMDIST

DISTRIB.NORM.N

NORM.DIST

DISTRIB.NORM.ST

NORMSDIST

DISTRIB.NORM.ST.N

NORM.S.DIST

DISTRIB.POISSON

POISSON.DIST

DISTRIB.T

TDIST

DISTRIB.T.2T

T.DIST.2T

DISTRIB.T.DS

T.DIST.RT

DISTRIB.T.N

T.DIST

DISTRIB.WEIBULL

WEIBULL.DIST

DISTRIBF

F.DIST

DURATA

DURATION

DURATA.M

MDURATION

DURATA.P

PDURATION

 

E

 

E

AND

EFFETTIVO

EFFECT

ERR.STD.YX

STEYX

ERRORE.TIPO

ERROR.TYPE

ESC.PERCENT.RANGO

PERCENTRANK.EXC

ESC.PERCENTILE

PERCENTILE.EXC

ESC.QUARTILE

QUARTILE.EXC

EXP EXP

 

 

F

 

FALSO

FALSE

FATT.DOPPIO

FACTDOUBLE

FATTORIALE

FACT

FILTRO.XML

FILTERXML

FINE.MESE

EOMONTH

FISHER

FISHER

FISSO

FIXED

FOGLI

SHEETS

FOGLIO

SHEET

FRAZIONE.ANNO

YEARFRAC

FREQUENZA

FREQUENCY

FUNZ.ERRORE

ERF

FUNZ.ERRORE.COMP

ERFC

FUNZ.ERRORE.COMP.PRECISA

ERFC.PRECISE

FUNZ.ERRORE.PRECISA

ERF.PRECISE

FURIGANA

PHONETIC

 

G

 

GAMMA

GAMMA

GAUSS

GAUSS

GIORNI

DAYS

GIORNI.CED

COUPDAYS

GIORNI.CED.INIZ.LIQ

COUPDAYBS

GIORNI.CED.NUOVA

COUPDAYSNC

GIORNI.LAVORATIVI.TOT

NETWORKDAYS

GIORNI.LAVORATIVI.TOT.INTL

NETWORKDAYS.INTL

GIORNO

DAY

GIORNO.LAVORATIVO

WORKDAY

GIORNO.LAVORATIVO.INTL

WORKDAY.INTL

GIORNO.SETTIMANA

WEEKDAY

GIORNO360

DAYS360

GRADI

DEGREES

GRANDE

LARGE

 

H

 

HEX.BINARIO

HEX2BIN

HEX.DECIMALE

HEX2DEC

HEX.OCT

HEX2OCT

 

I

 

IDENTICO

EXACT

INC.PERCENT.RANGO

PERCENTRANK.INC

INC.PERCENTILE

PERCENTILE.INC

INC.QUARTILE

QUARTILE.INC

INDICE

INDEX

INDIRETTO

INDIRECT

INDIRIZZO

ADDRESS

INFO.DATI.TAB.PIVOT

GETPIVOTDATA

INT

INT

INT.CUMUL

CUMIPMT

INT.MATURATO.PER

ACCRINT

INT.MATURATO.SCAD

ACCRINTM

INTERCETTA

INTERCEPT

INTERESSE.RATA

ISPMT

INTERESSI

IPMT

INTERVALLO.DISTRIB.BINOM.N.

BINOM.DIST.RANGE

INV.BETA

BETAINV

INV.BETA.N

BETA.INV

INV.BINOM

BINOM.INV

INV.CHI

CHIINV

INV.CHI.QUAD

CHISQ.INV

INV.CHI.QUAD.DS

CHISQ.INV.RT

INV.F

FINV

INV.F.DS

F.INV.RT

INV.FISHER

FISHERINV

INV.GAMMA

GAMMAINV

INV.GAMMA.N

GAMMA.INV

INV.LOGNORM

LOGINV

INV.LOGNORM.N

LOGNORM.INV

INV.NORM

NORMINV

INV.NORM.N

NORM.INV

INV.NORM.S

NORM.S.INV

INV.NORM.ST

NORMSINV

INV.T

TINV

INV.T.2T

T.INV.2T

INVF

F.INV

INVT

T.INV

ISO.ARROTONDA.ECCESSO

ISO.CEILING

 

L

 

LIBERA

CLEAN

LN

LN

LN.GAMMA

GAMMALN

LN.GAMMA.PRECISA

GAMMALN.PRECISE

LOG

LOG

LOG10

LOG10

LUNGB

LENB

LUNGHEZZA

LEN

 

M

 

MAIUSC

UPPER

MAIUSC.INIZ

PROPER

MATR.DETERM

MDETERM

MATR.INVERSA

MINVERSE

MATR.PRODOTTO

MMULT

MATR.SOMMA.PRODOTTO

SUMPRODUCT

MATR.TRASPOSTA

TRANSPOSE

MATR.UNIT

MUNIT

MAX

MAX

MAX.PIÙ.SE

MAXIFS

MAX.VALORI

MAXA

MCD

GCD

MCM

LCM

MEDIA

AVERAGE

MEDIA.ARMONICA

HARMEAN

MEDIA.B

MIDB

MEDIA.DEV

AVEDEV

MEDIA.GEOMETRICA

GEOMEAN

MEDIA.PIÙ.SE

AVERAGEIFS

MEDIA.SE

AVERAGEIF

MEDIA.TRONCATA

TRIMMEAN

MEDIA.VALORI

AVERAGEA

MEDIANA

MEDIAN

MEMBRO.CUBO

CUBEMEMBER

MEMBRO.CUBO.CON.RANGO

CUBERANKEDMEMBER

MEMBRO.KPI.CUBO

CUBEKPIMEMBER

MESE

MONTH

MIN

MIN

MIN.PIÙ.SE

MINIFS

MIN.VALORI

MINA

MINUSC

LOWER

MINUTO

MINUTE

MODA

MODE

MODA.MULT

MODE.MULT

MODA.SNGL

MODE.SNGL

MULTINOMIALE

MULTINOMIAL

 

N

 

NOMINALE

NOMINAL

NON

NOT

NON.DISP

NA

NORMALIZZA

STANDARDIZE

NUM

N

NUM.CED

COUPNUM

NUM.RATE

NPER

NUM.SETTIMANA

WEEKNUM

NUM.SETTIMANA.ISO

ISOWEEKNUM

NUMERO.VALORE

NUMBERVALUE

 

O

 

O

OR

OCT.BINARIO

OCT2BIN

OCT.DECIMALE

OCT2DEC

OCT.HEX

OCT2HEX

OGGI

TODAY

ORA

HOUR

ORARIO

TIME

ORARIO.VALORE

TIMEVALUE

 

P

 

P.RATA

PPMT

PARI

EVEN

PEARSON

PEARSON

PENDENZA

SLOPE

PERCENT.RANGO

PERCENTRANK

PERCENTILE

PERCENTILE

PERMUTAZIONE

PERMUT

PERMUTAZIONE.VALORI

PERMUTATIONA

PHI

PHI

PI.GRECO

PI

PICCOLO

SMALL

PIÙ.SE

IFS

POISSON

POISSON

POTENZA

POWER

PREVISIONE

FORECAST

PREVISIONE.ETS

FORECAST.ETS

PREVISIONE.ETS.INTCONF

FORECAST.ETS.CONFINT

PREVISIONE.ETS.STAGIONALITÀ

FORECAST.ETS.SEASONALITY

PREVISIONE.ETS.STAT

FORECAST.ETS.STAT

PREVISIONE.LINEARE

FORECAST.LINEAR

PREZZO

PRICE

PREZZO.PRIMO.IRR

ODDFPRICE

PREZZO.SCAD

PRICEMAT

PREZZO.SCONT

PRICEDISC

PREZZO.ULTIMO.IRR

ODDLPRICE

PROBABILITÀ

PROB

PRODOTTO

PRODUCT

PROPRIETÀ.MEMBRO.CUBO

CUBEMEMBERPROPERTY

 

Q

 

QUARTILE

QUARTILE

QUOZIENTE

QUOTIENT

 

R

 

RADIANTI

RADIANS

RADQ

SQRT

RADQ.PI.GRECO

SQRTPI

RANGO

RANK

RANGO.MEDIA

RANK.AVG

RANGO.UG

RANK.EQ

RATA

PMT

REGR.LIN

LINEST

REGR.LOG

LOGEST

REND

YIELD

REND.PRIMO.IRR

ODDFYIELD

REND.SCAD

YIELDMAT

REND.TITOLI.SCONT

YIELDDISC

REND.ULTIMO.IRR

ODDLYIELD

RESTO

MOD

RICERCA

SEARCH

RICEV.SCAD

RECEIVED

RIF.COLONNA

COLUMN

RIF.RIGA

ROW

RIGHE

ROWS

RIMPIAZZA

REPLACE

RIPETI

REPT

RIT.INVEST.EFFETT

RRI

ROMANO

ROMAN

RQ

RSQ

 

S

 

SCARTO

OFFSET

SCEGLI

CHOOSE

SE

IF

SE.ERRORE

IFERROR

SE.NON.DISP.

IFNA

SEC

SEC

SECH

SECH

SECONDO

SECOND

SEGNO

SIGN

SEN

SIN

SENH

SINH

SERVIZIO.WEB

WEBSERVICE

SET.CUBO

CUBESET

SINISTRA

LEFT

SINISTRAB

LEFTB

SOGLIA

GESTEP

SOMMA

SUM

SOMMA.DIFF.Q

SUMX2MY2

SOMMA.PIÙ.SE

SUMIFS

SOMMA.Q

SUMSQ

SOMMA.Q.DIFF

SUMXMY2

SOMMA.SE

SUMIF

SOMMA.SERIE

SERIESSUM

SOMMA.SOMMA.Q

SUMX2PY2

SOSTITUISCI

SUBSTITUTE

SOSTITUISCI.B

REPLACEB

STRINGA.ESTRAI

MID

SUBTOTALE

SUBTOTAL

SWITCH

SWITCH

 

T

 

T

T

TAN

TAN

TANH

TANH

TASSO

RATE

TASSO.INT

INTRATE

TASSO.SCONTO

DISC

TENDENZA

TREND

TEST.CHI

CHITEST

TEST.CHI.QUAD

CHISQ.TEST

TEST.F

FTEST

TEST.T

TTEST

TEST.Z

ZTEST

TESTF

F.TEST

TESTO

TEXT

TESTO.FORMULA

FORMULATEXT

TESTO.UNISCI

TEXTJOIN

TESTT

T.TEST

TESTZ

Z.TEST

TIPO

TYPE

TIR.COST

IRR

TIR.VAR

MIRR

TIR.X

XIRR

TRONCA

TRUNC

TROVA

FIND

TROVA.B

FINDB

 

U

 

UNICODE

UNICODE

USDOLLAR

USDOLLAR

 

V

 

VA

PV

VAL.DISPARI

ISODD

VAL.ERR

ISERR

VAL.ERRORE

ISERROR

VAL.FORMULA

ISFORMULA

VAL.FUT

FV

VAL.FUT.CAPITALE

FVSCHEDULE

VAL.LOGICO

ISLOGICAL

VAL.NON.DISP

ISNA

VAL.NON.TESTO

ISNONTEXT

VAL.NUMERO

ISNUMBER

VAL.PARI

ISEVEN

VAL.RIF

ISREF

VAL.TESTO

ISTEXT

VAL.VUOTO

ISBLANK

VALORE

VALUE

VALORE.CUBO

CUBEVALUE

VALUTA

DOLLAR

VALUTA.DEC

DOLLARDE

VALUTA.FRAZ

DOLLARFR

VAN

NPV

VAN.X

XNPV

VAR

VAR

VAR.C

VAR.S

VAR.P

VAR.P

VAR.POP

VARP

VAR.POP.VALORI

VARPA

VAR.VALORI

VARA

VERO

TRUE

 

W

 

WEIBULL

WEIBULL

 

X

 

XOR

XOR

Segui ML Training sui Social:
Facebook - LinkedIn - Twitter - Google+

Posted: 15 Ott 16 By: Category: Blog Read 1673 times

Autore: Andrea Pacchiarotti

Per ordinare i fogli in senso crescente in base al nome è possibile utilizzare la routine seguente che, a seconda delle necessità, può essere eseguita:

  1. da un pulsante posto:
    • sulla barra di accesso rapido
    • sulla barra multifunzione
    • sul foglio stesso
  2. al caricamento del file sfruttando l’evento Private Sub Workbook_Open()

Dim foglio As Worksheet
Dim prec As String
Dim corr As String
Dim sposta As Boolean
Dim primo As Boolean
Dim i As Integer
sposta = True
While sposta = True
   primo = True
   sposta = False
   prec = ""
   corr = ""
   For Each foglio In Worksheets
      If primo Then
         corr = LCase(foglio.Name)
         primo = False
      Else
         prec = corr
         corr = LCase(foglio.Name)
      End If
      If prec <> "" Then
         If corr < prec Then
            sposta = True
            foglio.Move Before:=Sheets(prec)
         End If
      End If
   Next
Wend

Segui ML Training sui Social:
Facebook - LinkedIn - Twitter - Google+

Posted: 09 Ott 16 By: Category: Blog Read 869 times

Autore: Andrea Pacchiarotti

Per sostenere con successo le certificazioni ECDL, EIPASS ed IC3 di Excel è necessario conoscere, tra gli altri argomenti, anche le funzioni, gli operatori e i messaggi d'errore.

FUNZIONI E OPERATORI

La forma di una funzione generica è: =NomeFunzione(argomento1;argomento2;…;argomentoN)
Può essere scritta in maiuscolo e/o minuscolo, ma senza spazi ad eccezione, se necessario, delle stringhe della funzione SE e CONTA.SE
L’argomento può essere: riferimento di cella, numero, testo, intervallo
L’intervallo è un gruppo di celle separate dal simbolo :, es. A1:A10 significa da A1 ad A10; separandole con ; ci si riferisce invece alle singole celle A1 e A10
Il ; è anche un separatore di argomenti come ad esempio nella seguente formula: =SOMMA(A1:A10;C20:C25) che somma le celle dell’intervallo A1:A10 a quelle dell’intervallo C20:C25.
Al posto dell’intervallo posso anche usare un nome che precedentemente ho assegnato ad esso, nell’esempio precedente la formula potrebbe diventare: =SOMMA(GENNAIO;FEBBRAIO)

Operatori aritmetici o matematici
  Funzioni Esempio Esempio Libreria Argomenti
^ Elevamento a potenza =base^esponente
=POTENZA(base;esponente)
=3^2
=POTENZA(A1;A2)
=POTENZA(3;2) Dà 9
Matematiche e Trigonometriche 2
* Moltiplicazione =moltiplicando*moltiplicatore
=PRODOTTO(numero;numero)
=3*2
=PRODOTTO(A1;A2)
=PRODOTTO(3;2) Dà 6
Matematiche e Trigonometriche 2 (fino a 255)
/ Divisione =numeratore/denominatore
=QUOZIENTE(numeratore;denominatore)
Il numeratore è il dividendo, il denominatore il divisore
=RESTO(dividendo;divisore)
=5/2
=QUOZIENTE(A1;A2)
=QUOZIENTE(5;2) Dà 2 =RESTO(A1;A2)
=RESTO(5;2) Dà 1
Matematiche e Trigonometriche 2
+ Addizione =addendo+addendo
=SOMMA(cella:cella)
=3+2
=SOMMA(A1:A10)
Matematiche e Trigonometriche 1 (fino a 255)
- Sottrazione =minuendo-sottraendo =3-2    

Operatore di concatenazione
  Funzioni Esempio Esempio Libreria Argomenti
&   =cella&cella
=CONCATENA(cella;cella)
=A1&A2
=CONCATENA(A1;A2)
  Testo 1 (fino a 255)

Operatori relazionali o di confronto
Maggiore
>= Maggiore uguale
Minore
<= Minore uguale
= Uguale
<>  Diverso

Operatori di riferimento
$A$1 Riferimento assoluto
$A1 Riferimento misto, assoluto di colonna, relativo di riga
A$1 Riferimento misto, assoluto di riga, relativo di colonna
A1 Riferimento relativo

Altre funzioni
Funzioni Esempio Libreria Argomenti
=OGGI() =OGGI() Data e Ora 0
=ADESSO() =ADESSO() Data e Ora 0
=MEDIA(cella:cella) =MEDIA(A1:A10) Statistiche 1 (fino a 255)
=MIN(cella:cella) =MIN(A1:A10) Statistiche 1 (fino a 255)
=MAX(cella:cella) =MAX(A1:A10) Statistiche 1 (fino a 255)
=CONTA.NUMERI(cella:cella) =CONTA.NUMERI(A1:A10) Statistiche 1 (fino a 255)
=CONTA.VALORI(cella:cella) =CONTA.VALORI(A1:A10) Statistiche 1 (fino a 255)
=CONTA.VUOTE(cella:cella) =CONTA.VUOTE(A1:A10) Statistiche 1 (fino a 255)
=CONTA.SE(cella:cella;criterio)
Il criterio va racchiuso tra “” se è una stringa
=CONTA.SE(A1:A10;”>10”)
=CONTA.SE(A1:A10;10)
=CONTA.SE(F9:F19;A1)
=CONTA.SE(A1:A10;”Anna Mei”)
Statistiche 2
=ARROTONDA(numero;cifre) =ARROTONDA(A1;1)
=ARROTONDA(1,952;1)
Matematiche e Trigonometriche 2
=RADQ(numero) =RADQ(A1)
=RADQ(100)
Matematiche e Trigonometriche 1
=SE(test;se_vero;se_falso)
Il se_vero e il se_falso (che non sono obbligatori) vanno racchiusi tra “” se sono stringhe
=SE(A2<=100;"No";"Sì, ok")
=SE(A2=100;A2+B2,"")
Logiche 3
È possibile annidare/nidificare le funzioni =SE(A1>89;"A";SE(A1>0;"B"))
=SE(E(A1>1;B1>5); "No";"Sì, ok")
Logiche  

MESSAGGI DI ERRORE

Errori in cui si può incorrere utilizzando le formule
#VALORE!: uso il tipo errato di argomento o operando. Es. =a1-a2-a3 dove in a2 c’è una stringa
#DIV/0!: divido un numero per 0 o per una cella vuota
#NOME?: nome di funzione errato o in altra lingua rispetto a quella di Excel
#RIF!: riferimento di cella non valido ovvero elimino celle (che è diverso dal cancellarne il contenuto) che fanno riferimento alla formula
#NUM!: argomenti dei valori numerici non validi per il tipo di funzione, es. =RADQ(-2) o calcolo > o < dei valori limite di Excel (±1*10^308)
#N/D? Nessun valore disponibile.
###### una colonna non sufficientemente larga o uso date o ore negative
Riferimento circolare: formula che usa come argomenti la stessa cella in cui si sta scrivendo la formula, es. in A3 scrivo =SOMMA(A1:A10). L’errore non è introdotto da #, ma da una finestra

Segui ML Training sui Social:
Facebook - LinkedIn - Twitter - Google+

Posted: 05 Ott 16 By: Category: Blog Read 979 times
ML TRAINING

    Via Sergio Forti, 23
00144 Roma // Italy

    +39 06 830 893 06
   +39 06 830 893 06

    Questo indirizzo email è protetto dagli spambots. È necessario abilitare JavaScript per vederlo.